I lost all my progress

Post all your technical problems here.
Post Reply
DarthAjax03
Posts: 1
Joined: Fri May 03, 2019 3:44 am

I lost all my progress

Post by DarthAjax03 » Fri May 03, 2019 3:54 am

I’ve been playing for only a few hours, got to lvl 12, bought some nice ships, done some quests, and all of a sudden, progress lost, lvl 1. The curious thing about it is that I still have my ships and the building levels are still the same, but I’ve lost all my money and I’m lvl 1... Help plz
User avatar
Drew458
Posts: 139
Joined: Tue Oct 02, 2018 1:24 pm
Location: New Jersey USA
Contact:

Re: I lost all my progress

Post by Drew458 » Wed May 22, 2019 1:17 am

I have no idea. I think sometimes the Cloud is not reliable. I hope you didn't press the New Game button by accident.

OTOH, you were only at level 12, so you really didn't lose all that much. Not trying to be unsympathetic, but I've been hit with bugs that cost me 4000 levels and half a billion in gold. That REALLY sucked.
gunslingingbird
Posts: 1
Joined: Sun May 26, 2019 8:45 pm

Re: I lost all my progress

Post by gunslingingbird » Sun May 26, 2019 8:48 pm

I just had the same problem. I started at level 12 and got to level 36 with a few new ships, and when I came back I'm back to level 12, and all my ships, money, and progress are gone.
User avatar
Drew458
Posts: 139
Joined: Tue Oct 02, 2018 1:24 pm
Location: New Jersey USA
Contact:

Re: I lost all my progress

Post by Drew458 » Mon May 27, 2019 3:04 pm

Ok I will forward this to Artik. It may be a level 12 issue.
Post Reply